Sun Java System Directory Server Enterprise Edition 6.2 发行说明

目录代理服务器中的已知问题和限制

本部分列出了发行时的已知问题和限制。

目录代理服务器限制

本部分列出了产品限制。

不要手动更改文件权限。

在某些情况下,对已安装的 Directory Server Enterprise Edition 产品文件的权限进行更改可能会导致软件无法正常运行。只能按照产品文档中的说明或 Sun 支持人员的指导来更改文件权限。

要解除此限制,请以具有适当用户和组权限的用户身份来安装产品和创建服务器实例。

无法续订自签名的服务器证书。

创建自签名服务器证书时,请确保指定足够长的有效期,这样便无需续订证书。

Directory Proxy Server 6.2 中的已知问题

本部分列出了在发行 Directory Proxy Server 6.2 时发现的已知问题。

5042517

LDIF 数据视图、JDBC 数据视图、联接数据视图和访问控制数据视图不支持修改 DN 操作。

6255952

定义本地代理 ACI 时,使用“获得有效的权限控制”的操作可能无法返回正确信息。

6356465

目录代理服务器拒绝那些将子类型指定给目标属性的 ACI,如 targetattr = "locality;lang-fr-ca"

6357160
dpconf 命令不拒绝属性值中的新行字符和换行字符。应避免在设置属性值时使用新行字符和换行字符。

6359601

配置 ACI 时,目录代理服务器返回的结果与对 LDAP 数据源直接搜索返回的结果不同。

6360059

目录代理服务器无法恢复在数据源连接失败后已恢复的 JDBC 数据源连接。 目录代理服务器仅在重新启动目录代理服务器实例后才能恢复连接。

6374344

重新启动目录服务器数据源后,目录代理服务器返回操作错误,指明服务器无法读取绑定响应。

6383532

更改验证模式配置后,必须重新启动目录代理服务器。

6386073

为目录代理服务器生成 CA 签名证书请求后,可以刷新目录服务控制中心。然后目录服务控制中心会将证书标记为自签名。

6388022

当客户端应用程序使用 SSL 进行连接时,可以配置为使用 SSL 连接。如果目录代理服务器所用的 SSL 端口不正确,则目录代理服务器会在进行安全搜索后关闭所有连接。

6390118

将目录代理服务器配置为使用基于客户端应用程序凭证(而非代理授权)的验证时,它将无法正确计算引用跃点数。

6390220

只有在最初创建数据视图时,目录代理服务器才允许将该数据视图的 base-dn 属性设置为根 DN ""

6410741

目录服务控制中心将值作为字符串进行排序。因此,在目录服务控制中心中对数字进行排序时,数字将被视为字符串。

对 0、20 和 100 进行升序排序的结果为 0、100、20。对 0、20 和 100 进行降序排序的结果为 20、100、0。

6415184

无法在 DSCC 中创建路径包含多字节字符的目录代理服务器实例以启动或执行其他常规任务。

可通过用于创建该实例的字符集来解决其中的某些问题。请使用以下命令设置字符集:

通过目录代理服务器访问目录服务器时,Access Manager 在重新启动目录服务器后遇到与持久性搜索相关的缓存问题。

要解决此问题,请在重新启动目录服务器后重新启动 Access Manager 或目录代理服务器。

要进一步进行优化,可以增加 Access Manager 尝试次数以及尝试之间的延迟时间,以便重新建立持久性搜索连接。可以通过更改 AMConfig.properties 文件中的下列属性来增大这些参数。

增大 com.iplanet.am.event.connection.num.retries ,该属性表示尝试次数。默认值为 3 次尝试。

如果使用配置了 DB2 数据库的 JDBC 数据视图执行搜索,并且在搜索结果中返回大量条目,则在返回 1344 个条目后可能会发生错误。

要解除这一限制,可以增加大型软件包的数量,方法是将 CLI/ODBC 配置关键字 CLIPkg 的值最大设置为 30 。但搜索结果仍被限定为最多 11712 个条目。

有关详细信息,请参见 DB2 文档。

6491133

使用目录服务控制中心创建自签名证书时,不要使用多字节字符作为证书名称。

6491845

目录服务控制中心不显示允许通过目录代理服务器的默认 LDAP 控件。

6492376

配置 JDBC 语法后,必须重新启动目录代理服务器才能使更改生效。

6493349

更改现有的排除子树或备用搜索基的 DN 时,目录服务控制中心会删除逗号。

6494540

首次启用或禁用非安全 LDAP 访问后,必须重新启动目录代理服务器才能使更改生效。

6495395

使用 split 的虚拟目录宏未正常工作。

6497547

时间限制和大小限制设置仅适用于 LDAP 数据源。

6497992

使用命令 dpadm set-flags cert-pwd-store=off 后,无法使用目录服务控制中心重新启动目录代理服务器。

6500298

使用 dpadm 命令的 jvm-args 标志并重新启动服务器时,无法为 Java 虚拟机成功分配超过 2 GB 的内存。

要解决此问题,请使用 dpadm stop dpadm start ,而不要使用 dpadm restart

6501867

dpadm start 命令中使用由 ASCII 和多字节字符组成的服务器实例名称时,该命令会失败。

6505112

在现有的连接处理程序上设置 data-view-routing-custom-list 属性时发生错误,因为数据视图名称中包含必须转义的字符(如逗号)。

要解决此问题,请不要使用包含必须转义的字符的数据视图名称。例如,不要使用包含 DN 的数据视图名称。

6510583

与以前的版本不同,如手册页 allowed-ldap-controls(5dpconf) 中所述,目录代理服务器 在默认情况下不允许使用服务器端排序控件。

通过在允许的 LDAP 控件(由 allowed-ldap-controls 属性指定)列表中添加 server-side-sorting ,可以使目录代理服务器支持服务器端排序控件。

$ dpconf set-server-prop \
 allowed-ldap-controls:auth-request \
 allowed-ldap-controls:chaining-loop-detection \
 allowed-ldap-controls:manage-dsa \
 allowed-ldap-controls:persistent-search \
 allowed-ldap-controls:proxy-auth-v1 \
 allowed-ldap-controls:proxy-auth-v2 \
 allowed-ldap-controls:real-attributes-only \
 allowed-ldap-controls:server-side-sorting

请注意,使用目录代理服务器的 DN 重命名功能时,重复的 DN 部分将被重命名为一个替换部分。

例如,要将以 o=myCompany.com 结尾的 DN 重命名为以 dc=com 结尾。对于 DN 与原始部分重复的条目(如 uid=userid,ou=people,o=myCompany.com,o=myCompany.com),重命名后所生成的 DN 为 uid=userid,ou=people,dc=com,而不是 uid=userid,ou=people,o=myCompany.com,dc=com

6517615

用于通过目录代理服务器访问 Oracle 9 的 JDBC 连接配置可能不像文档中所述的那样简便。

请考虑以下配置。您有一台在主机 myhost 的端口 1537 上侦听的 Oracle 9 服务器,其中包含系统标识符 (system identifier, SID) 为 MYINST 的实例。该实例具有数据库 MYNAME.MYTABLE

通常,要配置对 MYTABLE 的访问,需要设置以下属性。

在 JDBC 数据源上,设置 db-name:MYINST

restart_on="none" type="service"> <service_fmri value="svc:/network/initial:default"/> </dependency> + <dependency name="nameservice" grouping="require_all" \ + restart_on="none" type="service"> + <service_fmri value="svc:/milestone/name-services"/> + </dependency> <exec_method type="method" name="start" exec="%%%INSTALL_PATH%%%/bin/dsadm start --exec %{sunds/path}"...

如果与在 JDBC 对象类中找到的 DN 模式相匹配的 RDBMS 表中包含重复条目,则在针对 JDBC 数据视图执行搜索时,目录代理服务器将返回重复的子树(非叶)节点。 例如,如果 JDBC 对象类中包含 DN 模式 ou ,并且映射到 JDBC 属性 ou 的 RDBMS 列中包含重复的条目(如 sales ),则搜索结果中将显示重复的节点,如 ou=sales

要解决此问题,请执行以下操作:

在具有 DN 模式 ou 的 JDBC 对象类中,将 RDBMS 表名替换为 RDBMS 视图名称。这种方法的限制是,由于 RDBMS 视图是只读的,因此,无法通过目录代理服务器添加任何 JDBC 属性 ou 值。

6590460

在 Solaris 9 x86 上的简体中文和繁体中文中,没有翻译 dpadm show-cert dps-instance-path 命令输出中的字符串 owner

6592543

在法语语言环境中,提示确认停止或取消注册服务器的弹出式窗口显示双撇号。